Welcome to the Java Programming Forums

The professional, friendly Java community. 21,500 members and growing!

The Java Programming Forums are a community of Java programmers from all around the World. Our members have a wide range of skills and they all have one thing in common: A passion to learn and code Java. We invite beginner Java programmers right through to Java professionals to post here and share your knowledge. Become a part of the community, help others, expand your knowledge of Java and enjoy talking with like minded people. Registration is quick and best of all free. We look forward to meeting you.


Members have full access to the forums. Advertisements are removed for registered users.

Results 1 to 2 of 2

Thread: Timeout waiting for Oracle WebLogic Server v10.3 at localhost to start

  1. #1
    Junior Member
    Join Date
    Sep 2011
    Thanked 0 Times in 0 Posts

    Default Timeout waiting for Oracle WebLogic Server v10.3 at localhost to start

    I am trying to run .portal file using "Run on server" option in Workshop for weblogic.
    After doing this, its trying to start the server Oracle weblogic server v10.3 at localhost and then publish my module.
    Server view status shows as "State" as "Starting" and "Status" as "Synchronizing". When status reaches 82% it gets stopped there for a long time, and when 83% comes up, I can see the "State" as "Stopped" and "Status" as "Republish". And then an error window with title as "Problem Occured" and contents saying, Starting server- Oracle weblogic server v10.3 at localhost (Time of error: ...) Details >> Timeout waiting for Oracle WebLogic Server v10.3 at localhost to start. Server did not start after 480s.

    But the console tab (when I give the startup & Deployment option as "Launch Weblogic server in eclipse console) shows,
    <Sep 8, 2011 6:15:03 PM IST> <Notice> <WebLogicServer> <BEA-000365> <Server sta
    e changed to STARTING> (final step alone I pasted)
    Before this I can see, WLS Start mode = Development, setting Classpath ,
    <Sep 8, 2011 5:56:36 PM IST> <Notice> <Log Management> <BEA-170019> <The server
    log file C:\bea\user_projects\domains\myPortalDomain\server s\AdminServer\logs\Ad
    minServer.log is opened. All server side log events will be written to this file

    When I checked Adminserver file its having,
    <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1315487671986> <BEA-160151> <Registered library Extension-Name: wlp-groupspace-app-lib, Specification-Version: 10.3, Implementation-Version: (EAR).>
    And many more similar entries...

    Also there is Adminserver.logxxx file which is having,
    ####<Sep 8, 2011 5:33:58 PM IST> <Warning> <JDBC> <AdminServer> <[ACTIVE] ExecuteThread: '2' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1315483438048> <BEA-001129> <Received exception while creating connection for pool "portalDataSourceNeverXA": SQL-server rejected establishment of SQL-connection. Pointbase Server may not be running on localhost at port 9093.>
    ####<Sep 8, 2011 5:33:58 PM IST> <Info> <JDBC> <CINTNCHEOLY0GX7> <AdminServer> <[ACTIVE] ExecuteThread: '2' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1315483438267> <BEA-001156> <Stack trace associated with message 001129 follows:

    java.sql.SQLException: SQL-server rejected establishment of SQL-connection. Pointbase Server may not be running on localhost at port 9093.
    at com.pointbase.dbexcp.dbexcpException.getSQLExcepti on(Unknown Source)
    at com.pointbase.net.netJDBCConnection.a(Unknown Source)
    at com.pointbase.net.netJDBCConnection.<init>(Unknown Source)
    at com.pointbase.net.netJDBCDriver.getConnection(Dash oA10*..:170)
    at com.pointbase.net.netJDBCDriver.connect(DashoA10*. .:94)
    at com.pointbase.jdbc.jdbcUniversalDriver.getConnecti on(Unknown Source)
    at com.pointbase.jdbc.jdbcUniversalDriver.connect(Unk nown Source)
    at weblogic.jdbc.common.internal.ConnectionEnvFactory .makeConnection(ConnectionEnvFactory.java:316)
    at weblogic.jdbc.common.internal.ConnectionEnvFactory .createResource(ConnectionEnvFactory.java:217)
    at weblogic.common.resourcepool.ResourcePoolImpl.make Resources(ResourcePoolImpl.java:1109)
    at weblogic.common.resourcepool.ResourcePoolImpl$Reso urcePoolMaintanenceTask.timerExpired(ResourcePoolI mpl.java:2282)
    at weblogic.timers.internal.TimerImpl.run(TimerImpl.j ava:273)
    at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapte rImpl.run(SelfTuningWorkManagerImpl.java:516)
    at weblogic.work.ExecuteThread.execute(ExecuteThread. java:201)
    at weblogic.work.ExecuteThread.run(ExecuteThread.java :173)

    And many more entries like the above...

    I even tried startup & Deployment option as "Start weblogic server in Expressmode" and still same error I am getting and this time instead of in eclipse console, I can see command prompt and here also showing "Server state changed to STARTING"

    FYI, I created domain with runtime JRocket 1.6.0_05.

    I even tried to clean build the portal project and publish using clean option. Still same problem coming

    FYI, my system is having 1 GB RAM only and bit slow. Could this be a problem or something else? Please suggest.
    Thanks in advance.

  2. #2
    Crazy Cat Lady KevinWorkman's Avatar
    Join Date
    Oct 2010
    Washington, DC
    My Mood
    Thanked 636 Times in 540 Posts

    Default Re: Timeout waiting for Oracle WebLogic Server v10.3 at localhost to start

    This thread has been cross posted here:


    Although cross posting is allowed, for everyone's benefit, please read:

    Java Programming Forums Cross Posting Rules

    The Problems With Cross Posting

    Useful links: How to Ask Questions the Smart Way | Use Code Tags | Java Tutorials
    Static Void Games - Play indie games, learn from game tutorials and source code, upload your own games!

Similar Threads

  1. Timeout method
    By kafka82 in forum Loops & Control Statements
    Replies: 1
    Last Post: July 26th, 2011, 04:17 PM
  2. Mysql url pointer to server instead of localhost
    By kurt-hardy in forum JDBC & Databases
    Replies: 3
    Last Post: April 12th, 2011, 04:32 AM
  3. JNLP webstart application in localhost
    By Jhovarie in forum Threads
    Replies: 2
    Last Post: February 14th, 2011, 06:53 PM
  4. Replies: 6
    Last Post: September 19th, 2010, 08:33 PM
  5. Session Timeout in LDAP
    By retail_deepa in forum Java Servlet
    Replies: 0
    Last Post: August 4th, 2009, 03:26 AM