Welcome to the Java Programming Forums


The professional, friendly Java community. 21,500 members and growing!


The Java Programming Forums are a community of Java programmers from all around the World. Our members have a wide range of skills and they all have one thing in common: A passion to learn and code Java. We invite beginner Java programmers right through to Java professionals to post here and share your knowledge. Become a part of the community, help others, expand your knowledge of Java and enjoy talking with like minded people. Registration is quick and best of all free. We look forward to meeting you.


>> REGISTER NOW TO START POSTING


Members have full access to the forums. Advertisements are removed for registered users.

Results 1 to 2 of 2

Thread: problem with signing and webstart

  1. #1
    Junior Member
    Join Date
    Sep 2011
    Posts
    25
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question problem with signing and webstart

    hi everyone
    I am having a new problem which used to work perfectly
    I have a java project that depends on another libraries (other netbeans projects)
    I just changed my computer and imported all the projects. When running the main project without java web start it works fine
    when I compile and upload the files onto the server (the /lib, main .jar and .jnlp) and run the jnlp, it starts downloading the application and then appear an error

    Error: The JAR resources of the JNLP file aren´t signed by the same certificate
    (I dont know exactly whats the msg in english, I am traslating from spanish xD
    Error: Los recursos JAR del archivo JNLP no están firmados por el mismo certificado)

    and the first line of Exception tab says:
    JNLPException[category: Error de ejecución de archivo : Exception: null : LaunchDesc:

    It's weird because the only thing I did was to import all the projects and fix the reference problems with libraries and the previous application was working perfectly on the server

    Any idea?

    Thanks a lot!


  2. #2
    Junior Member
    Join Date
    Sep 2011
    Posts
    25
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Re: problem with signing and webstart

    Problem solved! this post can be deleted

    the problem was that I was importing the third-app libraries (.jars) from a folder outside all the projects, and they were supposed to be imported from the dist/lib of the project that uses the library!

Similar Threads

  1. Replies: 3
    Last Post: January 5th, 2012, 12:44 AM
  2. JNLP webstart application in localhost
    By Jhovarie in forum Threads
    Replies: 2
    Last Post: February 14th, 2011, 05:53 PM
  3. Using 1.5 jre/webstart on a computer with 1.6 installed
    By qman32 in forum What's Wrong With My Code?
    Replies: 0
    Last Post: January 27th, 2011, 11:29 AM

Tags for this Thread