Welcome to the Java Programming Forums

The professional, friendly Java community. 21,500 members and growing!

The Java Programming Forums are a community of Java programmers from all around the World. Our members have a wide range of skills and they all have one thing in common: A passion to learn and code Java. We invite beginner Java programmers right through to Java professionals to post here and share your knowledge. Become a part of the community, help others, expand your knowledge of Java and enjoy talking with like minded people. Registration is quick and best of all free. We look forward to meeting you.


Members have full access to the forums. Advertisements are removed for registered users.

Results 1 to 1 of 1

Thread: 600

  1. #1
    Junior Member
    Join Date
    May 2013
    Thanked 0 Times in 0 Posts

    Default 600

    Recent times our Application users are getting the below Middle Tier error while they trying to do MvbOrgType override / Merge for a source location and this issue won’t occur for all MvbOrgType override/ Merge records.

    When we worked with CMA users we learned that for the failure record, if they try resubmitting the same record it works. In rare scenario,we used to restart the FRODO weblogic server after that MvbOrgType override/Merge for a source location is working fine even though it's failed earlier.

    We have analyzed by code walkthrough and found that this error message got triggered during Standardization process. We tried to reproduce the same error in Test environment but no luck.

    The Scenario that we tried to reproduce in TEST environment:-

    1) We have selected same record and followed the same steps in the TEST environment but it's successfully submitted.

    2) We have tried submitting MvbOrgType override with more than one users logged in CMA but it's successfully submitted.

    3) We have stopped the Standardization services and resubmitted it but it's successfully submitted.

    We have given the Log and Code part as well below.

    “[2013 04 10 10:26:08] com.merck.mvd.cma.commands.SourceLocationSaveComma nd ERROR [Ajp13Processor[8057][7]] Problem while Calling the Business MethodMessage Code:600, Message: com.merck.mvd.middletier.business.BusinessExceptio n: Message Code:600, Message: SourceLocationId:25612076

    Message Code:600, Message: com.merck.mvd.middletier.business.BusinessExceptio n: Message Code:600, Message: SourceLocationId:25612076

    [2013 04 10 10:26:08] com.merck.mvd.cma.util.CMAUtility ERROR [Ajp13Processor[8057][7]] Exception is Message Code:600, Message: com.merck.mvd.middletier.business.BusinessExceptio n: Message Code:600, Message: SourceLocationId:25612076”.



    * Executes the standardization method for the source location. This needs to

    * be done immediately after an override is applied or expired. The requirements

    * state that an override will become effective immediately, so the record can

    * not be stored into a queue and wait until it can be processed. This must be

    * done synchronously.


    private void standardize(SourceLocationEntityLocal p_srcLoctn) throws





    * Business rules for standardizing a location.

    * @ejb.interface-method view-type="local"

    * @param iDummyParameter this parameter is here because of a defect in javadoc with JDK 1.4.1

    * without this param javadoc and ejbgen won't generate this method on the local interface

    * because it is overloaded. To do: test this without the param in future versions of javadoc

    * @param p_sourceLocationEntity local interface for the source location entity bean

    * @throws BusinessException

    * @throws IllegalArgumentException


    public void standardize(SourceLocationEntityLocal p_sourceLocationEntity)

    throws BusinessException {

    updateSourceLocation(p_sourceLocationEntity,standa rdizedSourceLocation);


    Please anyone provide some idea reg the root cause for this Issue..

    Thanks in Advance,.
    Last edited by sasidharan_t; May 9th, 2013 at 04:57 AM. Reason: Added complete details