Welcome to the Java Programming Forums

The professional, friendly Java community. 21,500 members and growing!

The Java Programming Forums are a community of Java programmers from all around the World. Our members have a wide range of skills and they all have one thing in common: A passion to learn and code Java. We invite beginner Java programmers right through to Java professionals to post here and share your knowledge. Become a part of the community, help others, expand your knowledge of Java and enjoy talking with like minded people. Registration is quick and best of all free. We look forward to meeting you.


Members have full access to the forums. Advertisements are removed for registered users.

Results 1 to 2 of 2

Thread: CAS Configuration Problem

  1. #1
    Junior Member
    Join Date
    Jul 2010
    Thanked 0 Times in 0 Posts

    Default CAS Configuration Problem

    I am facing a problem while configuring CAS with my application in local. The description is as below:

    Presently we have an application ABC which is deployed on a server using Tomcat.This application authenticates using CAS. The production version is running well and we have no issues. But now I have to make some enhancements in the application and deploy it again.

    I have setup the code using eclipse in my PC(WIN XP) and the war file is also ready. As I want to focus on my application only, I tried to reuse the authentication mechanism of CAS of production with my local version of application. I made the necessary changes in web.xml file of my application for CAS. When I run the application in local using http://localhost:8081/dev_abc.. then it successfully redirects to CAS. After entering the ID and password, it should return to my local application war and run the code. But it fails with the exception edu.yale.its.tp.cas.client.CASAuthenticationExcept ion: Unable to validate ProxyTicketValidator and Handshake Exception.

    After this I came to know that I should have my cacerts file in Java, updated with the server certificate. I exported the certificate file of CAS server as .cer file and tried the keytool command to include it in my cacerts. It was done fine as per the steps mentioned in different forums. But still it didnt work. I tried again doing the same but then keytool coomand failed with following display:

    C:\j2sdk1.4.2_05\bin>keytool -import -file cas.domain.com.cer -alias cas_cert -keypass cas_cert -trustcacerts -keystore C:\Program Files\Java\jdk1.5.0\jre\lib\
    keytool usage:

    -certreq [-v] [-alias <alias>] [-sigalg <sigalg>]
    [-file <csr_file>] [-keypass <keypass>]
    [-keystore <keystore>] [-storepass <storepass>]
    [-storetype <storetype>] [-provider <provider_class_name>] ...

    -delete [-v] -alias <alias>
    [-keystore <keystore>] [-storepass <storepass>]
    [-storetype <storetype>] [-provider <provider_class_name>] ...

    ---------------- and other keytool options..

    Please help that what exactly needs to be done here and also advice if my approach to use existing CAS of production server is correct or I need to configure CAS too in my local tomcat..

    I shall be highly obliged with any suggestions..

    Regards.. Prashant

  2. #2
    Super Moderator Norm's Avatar
    Join Date
    May 2010
    Eastern Florida
    Thanked 2,445 Times in 2,396 Posts

    Default Re: CAS Configuration Problem

    See posts at CAS certificate issue - Java Forums

Tags for this Thread