Welcome to the Java Programming Forums

The professional, friendly Java community. 21,500 members and growing!

The Java Programming Forums are a community of Java programmers from all around the World. Our members have a wide range of skills and they all have one thing in common: A passion to learn and code Java. We invite beginner Java programmers right through to Java professionals to post here and share your knowledge. Become a part of the community, help others, expand your knowledge of Java and enjoy talking with like minded people. Registration is quick and best of all free. We look forward to meeting you.


Members have full access to the forums. Advertisements are removed for registered users.

Results 1 to 1 of 1

Thread: [help] the application file (.jad) for application does not appear to be the ....

  1. #1
    Junior Member ordinarypeople's Avatar
    Join Date
    Apr 2010
    Thanked 1 Time in 1 Post

    Default [help] the application file (.jad) for application does not appear to be the ....

    * the problem solved, i`m run the application via OTA provisioning in WTK 3.0 n suddenly its work...
    * but if i`m run it from netbeans its still error..

    hi i`m novice in JAVA ME/J2ME n trying to build sms application....

    but when i run my application in netbeans via OTA provisioning i got this errori:

    the application file (.jad) for application does not appear to be the correct type. contact aplication provider for more information
    how to resolve this error n how my aplication can run in via OTA provisioning ?

    sorry for my bad English

    i use netbeans 6.7.1, wtk 3.0, jdk1.6.0_18

    [spoiler=error netbeans]
    Copying 1 file to G:\CoRe Of StReSS\java\cb\SMSbeta7a\dist\nbrun2645283988296728111
    Copying 1 file to G:\CoRe Of StReSS\java\cb\SMSbeta7a\dist\nbrun2645283988296728111
    Jad URL for OTA execution: http://localhost:8082/servlet/org.netbeans.modules.mobility.project.jam.JAMServlet/G%3A/CoRe+Of+StReSS/java/cb/SMSbeta7a/dist//smsbeta7a.jad
    Starting emulator in execution mode
    Installing suite from: http://localhost:8082/servlet/org.netbeans.modules.mobility.project.jam.JAMServlet/G%253A/CoRe%2bOf%2bStReSS/java/cb/SMSbeta7a/dist//smsbeta7a.jad
    *** Error ***
    A problem occured during deploying application from http://localhost:8082/servlet/org.netbeans.modules.mobility.project.jam.JAMServlet/G%253A/CoRe%2bOf%2bStReSS/java/cb/SMSbeta7a/dist//smsbeta7a.jad
    Uknown error: InvalidJadException: Reason = 37
    Cannot process "-Xjam:run=" command.
    You must supply a parameter for "run" command!
    emulator [arguments]
    In order to get commands supported by given device run:
    emulator.exe -Xdevice:<device name> -Xquery
    Generic list of arguments is:
    -version           Display version information about the emulator
    -help              Display list of valid arguments
    -classpath, -cp    The class path for the VM
    -D<name>=<value>   Set a system property
    -Xdebug            Use a remote debugger
                       Debugging options
    -Xdevice:<device>  Select a device skin for the emulator
                       Set the MIDlet suite's security domain
    -Xquery            Print device information
    -Xjam[:install=<JAD file url> | force | list | storageNames |
           run=[<storage name> | <storage number>] |
           remove=[<storage name> | <storage number> | all]]
                       Java Application Manager and support
                       for Over The Air provisioning (OTA)
    -Xautotest:<JAD file url>
                       Run in autotest mode
    -Xdescriptor:<JAD file name>
                       The JAD file to be executed
    G:\CoRe Of StReSS\java\cb\SMSbeta7a\nbproject\build-impl.xml:889: Execution failed with error code 1.
    BUILD FAILED (total time: 6 seconds)
    Last edited by ordinarypeople; April 5th, 2010 at 02:08 AM.
    Uncaught exception: MYBRAIN.lang.NullPointerException 0.

Similar Threads

  1. application id not found
    By pradeepsetty in forum Java IDEs
    Replies: 3
    Last Post: June 2nd, 2010, 02:37 AM
  2. Java Application Help...
    By Brian in forum Java ME (Mobile Edition)
    Replies: 0
    Last Post: March 25th, 2010, 07:38 AM
  3. An RMI-IIOP Application
    By Quicksliver in forum What's Wrong With My Code?
    Replies: 0
    Last Post: February 19th, 2010, 11:23 PM
  4. Replies: 0
    Last Post: December 3rd, 2009, 04:43 PM
  5. Help with Java Application
    By Riston in forum File I/O & Other I/O Streams
    Replies: 1
    Last Post: November 19th, 2009, 07:17 PM