Welcome to the Java Programming Forums


The professional, friendly Java community. 21,500 members and growing!


The Java Programming Forums are a community of Java programmers from all around the World. Our members have a wide range of skills and they all have one thing in common: A passion to learn and code Java. We invite beginner Java programmers right through to Java professionals to post here and share your knowledge. Become a part of the community, help others, expand your knowledge of Java and enjoy talking with like minded people. Registration is quick and best of all free. We look forward to meeting you.


>> REGISTER NOW TO START POSTING


Members have full access to the forums. Advertisements are removed for registered users.

Results 1 to 2 of 2

Thread: github java collaborotion issue

  1. #1
    Junior Member
    Join Date
    Apr 2020
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default github java collaborotion issue

    Hello everyone!

    I'm starting my path with java and one of my steps is to create project via github as collaboration with someone else. I have created many repositories and tried to do it many ways, however each time when my collabolator is cloning it and try to run it is not possible . When we do it rewers it is the same. It looks like project in IntelliJ is read only without possibility to run it. I suspect it is some dummy issue with java version etc. or access rights but we are prety green in this field and spent lots of time trying to solve it but with no effects. Therefore I hope someone can help us, thank you in advance. Here is print screen from IntelliJ:





    I'm almoust sure it is not a matter of code, becasue I have the same problem regardless what I wrote there.

    Here is the list of my actions:
    1. github repository creation
    2. clone of if on PC
    3. new project in IntelliJ - te same name and location
    4. create file
    5. push it on github
    6. give access to my collaborator
    7. he clone it on his PC and cannot do anything (on my PC it is working)

    what I'm doing wrong?
    <?xml version="1.0" encoding="UTF-8"?>
    <module type="JAVA_MODULE" version="4">
      <component name="NewModuleRootManager" inherit-compiler-output="true">
        <exclude-output />
        <content url="file://$MODULE_DIR$">
          <sourceFolder url="file://$MODULE_DIR$/src" isTestSource="false" />
        </content>
        <orderEntry type="inheritedJdk" />
        <orderEntry type="sourceFolder" forTests="false" />
      </component>
    </module>
    Attached Images Attached Images
    • File Type: jpg 1.jpg (45.4 KB, 1 views)
    Last edited by melwin515; April 19th, 2020 at 10:42 AM.

  2. #2
    Super Moderator Norm's Avatar
    Join Date
    May 2010
    Location
    Eastern Florida
    Posts
    23,254
    Thanks
    53
    Thanked 2,474 Times in 2,425 Posts

    Default Re: github java collaborotion issue

    Moved. Does not appear to be a java programming problem.

    Also posted here: https://coderanch.com/t/729418/ide/g...-collaborotion
    If you don't understand my answer, don't ignore it, ask a question.

Similar Threads

  1. [SOLVED] How to play a game imported from github into eclipse?
    By hemla in forum Java Theory & Questions
    Replies: 8
    Last Post: October 6th, 2013, 07:12 PM
  2. cmd java run issue
    By 0w1 in forum Java Theory & Questions
    Replies: 2
    Last Post: July 11th, 2013, 05:34 PM
  3. Detecting sound from microphone using Java. Issue specific to Java Versions
    By ssbattousai in forum File I/O & Other I/O Streams
    Replies: 3
    Last Post: July 11th, 2013, 03:06 AM
  4. Java Issue / Cache issue
    By VisualPK in forum What's Wrong With My Code?
    Replies: 1
    Last Post: April 14th, 2012, 08:43 PM