Welcome to the Java Programming Forums


The professional, friendly Java community. 21,500 members and growing!


The Java Programming Forums are a community of Java programmers from all around the World. Our members have a wide range of skills and they all have one thing in common: A passion to learn and code Java. We invite beginner Java programmers right through to Java professionals to post here and share your knowledge. Become a part of the community, help others, expand your knowledge of Java and enjoy talking with like minded people. Registration is quick and best of all free. We look forward to meeting you.


>> REGISTER NOW TO START POSTING


Members have full access to the forums. Advertisements are removed for registered users.

Results 1 to 4 of 4

Thread: application id not found

  1. #1
    Junior Member
    Join Date
    Jul 2009
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default application id not found

    Hi ,

    I am running my own built plug-in in Eclipse 3.4.2. I successfully built my plug-in but when i try run my plug-in, eclipse is displaying following below error
    !SESSION 2009-07-06 17:05:16.181 -----------------------------------------------
    eclipse.buildId=unknown
    java.version=1.5.0_16
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
    Command-line arguments: -dev

    !ENTRY org.eclipse.osgi 4 0 2009-07-06 17:05:37.164
    !MESSAGE Application error
    !STACK 1
    java.lang.RuntimeException: No application id has been found.
    at org.eclipse.equinox.internal.app.EclipseAppContain er.startDefaultApp(EclipseAppContainer.java:236)
    at org.eclipse.equinox.internal.app.MainApplicationLa uncher.run(MainApplicationLauncher.java:29)
    at org.eclipse.core.runtime.internal.adaptor.EclipseA ppLauncher.runApplication(EclipseAppLauncher.java: 110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseA ppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.ru n(EclipseStarter.java:386)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.ru n(EclipseStarter.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at org.eclipse.equinox.launcher.Main.invokeFramework( Main.java:549)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.ja va:504)
    at org.eclipse.equinox.launcher.Main.run(Main.java:12 36)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1 212)
    I modified config.ini by specifying plug-in name in "eclipse.application" attribute and enabled "eclipse.application.registerDescriptors".
    After that if i start eclipse , it wont start but throws an exception like "eclipse.application=myplugin is not found in registry" in log file.
    If i comment "eclipse.product" in config.ini leaving only "eclipse.application" and try to run eclipse same exception like "eclipse.application=myplugin is not found in registry" is displayed in log file.

    How to register my plug-in in registry ? Where will be that registry ? Is that is Window->Show View->Other->Plug-in Registry ?
    Where and How to specify my plug-in ID, So that the error "java.lang.RuntimeException: No application id has been found" can be removed ?

    Below is my config.ini file:
    -----------------------------------------------------
    #This configuration file was written by: org.eclipse.equinox.internal.frameworkadmin.equino x.EquinoxFwConfigFileParser
    #Wed Feb 11 19:26:47 EST 2009
    org.eclipse.update.reconcile=false
    eclipse.p2.profile=SDKProfile
    osgi.instance.area.default=@user.home/workspace
    osgi.framework=file\:plugins/org.eclipse.osgi_3.4.3.R34x_v20081215-1030.jar
    eclipse.buildId=M20090211-1700
    osgi.bundles=reference\:file\org.eclipse.equinox.s impleconfigurator_1.0.0.v20080604.jar@1\:start
    org.eclipse.equinox.simpleconfigurator.configUrl=f ile\org.eclipse.equinox.simpleconfigurator/bundles.info
    eclipse.product=org.eclipse.sdk.ide
    osgi.splashPath=platform\:/base/plugins/org.eclipse.platform
    eclipse.p2.data.area=@config.dir/../p2
    osgi.bundles.defaultStartLevel=4
    osgi.ws=gtk
    And my system configuration is as below...

    OS : Fedora 8
    Machine : i386
    Eclipse : eclipse-SDK-3.4.2-linux-gtk.tar.gz
    Java : 1.5 Update 16

    Please shed some light on this issue...

    Thanks in Advance
    Pradeep


  2. #2
    mmm.. coffee JavaPF's Avatar
    Join Date
    May 2008
    Location
    United Kingdom
    Posts
    3,336
    My Mood
    Mellow
    Thanks
    258
    Thanked 287 Times in 225 Posts
    Blog Entries
    4

    Default Re: application id not found

    Hello pradeepsetty. Welcome to the Java Programming Forums.

    I have no experience building my own eclipse plugins so I can't really offer any assistance.

    Hopefully by bumping this thread someone else will offer you a solution!
    Please use [highlight=Java] code [/highlight] tags when posting your code.
    Forum Tip: Add to peoples reputation by clicking the button on their useful posts.

    Looking for a Java job? Visit - Java Programming Careers

  3. #3
    Super Moderator Norm's Avatar
    Join Date
    May 2010
    Location
    Eastern Florida
    Posts
    22,321
    Thanks
    56
    Thanked 2,374 Times in 2,345 Posts

    Default Re: application id not found

    pradeepsetty,

    Could you tell me how you get error message texts from eclipse so they can be posted on a forum?

    Thanks,
    Norm

  4. #4
    Super Moderator Json's Avatar
    Join Date
    Jul 2009
    Location
    Warrington, United Kingdom
    Posts
    1,274
    My Mood
    Happy
    Thanks
    70
    Thanked 156 Times in 152 Posts

    Default Re: application id not found

    Norm, goto Window - Show View - Error Log

    // Json

Similar Threads

  1. Desktop Database Application
    By TCoomer in forum JDBC & Databases
    Replies: 2
    Last Post: June 4th, 2009, 04:51 PM
  2. Replies: 0
    Last Post: May 21st, 2009, 12:17 PM
  3. Replies: 1
    Last Post: April 29th, 2009, 07:26 AM
  4. How to know number of user downloading an application?
    By jazz2k8 in forum Java Theory & Questions
    Replies: 2
    Last Post: July 3rd, 2008, 05:34 AM