Welcome to the Java Programming Forums


The professional, friendly Java community. 21,500 members and growing!


The Java Programming Forums are a community of Java programmers from all around the World. Our members have a wide range of skills and they all have one thing in common: A passion to learn and code Java. We invite beginner Java programmers right through to Java professionals to post here and share your knowledge. Become a part of the community, help others, expand your knowledge of Java and enjoy talking with like minded people. Registration is quick and best of all free. We look forward to meeting you.


>> REGISTER NOW TO START POSTING


Members have full access to the forums. Advertisements are removed for registered users.

Results 1 to 10 of 10

Thread: New Member with an issue

  1. #1
    Junior Member
    Join Date
    Jul 2019
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default New Member with an issue

    I am an IT coordinator for a multiple truck and equipment dealership and help maintain close to 300 pc's and multiple servers. I am trying to troubleshoot a web page that can't load a Java Applet. Actually there are multiple pc's that can't and some that can. What forum would I post the issue in.

  2. #2
    Super Moderator Norm's Avatar
    Join Date
    May 2010
    Location
    Eastern Florida
    Posts
    22,205
    Thanks
    53
    Thanked 2,385 Times in 2,339 Posts

    Default Re: New Member with an issue

    Java Applets are not supported by most modern browsers. I think Internet Explorer 11 still does support Applets.
    Can you post more details?
    If you don't understand my answer, don't ignore it, ask a question.

  3. #3
    Junior Member
    Join Date
    Jul 2019
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Re: New Member with an issue

    From a win10 x64 with IE11 I'm trying to get to a web page and I get an error "... the SAPGUI for HTML Applet did not start within 30 seconds...". I attached a file with the errors. I have a working computer and copied all it's java settings and IE security settings and still get error. I have upgraded, I have deleted all, restarted, installed, restarted, I have done both the 32bit and 64bit, I have scrubbed pc with ccleaner and reinstalled. I have read and applied where applicable the advice in link below. I have done other things found on google. My trial computer is a fresh "out of the box" refurb. All AV has been dropped. I am fresh out of ideas. Help?
    Error1.jpgError2.jpgerror3.jpg

  4. #4
    Super Moderator Norm's Avatar
    Join Date
    May 2010
    Location
    Eastern Florida
    Posts
    22,205
    Thanks
    53
    Thanked 2,385 Times in 2,339 Posts

    Default Re: New Member with an issue

    the SAPGUI for
    What is SAPGUI? I have never heard of it.
    If you don't understand my answer, don't ignore it, ask a question.

  5. #5
    Junior Member
    Join Date
    Jul 2019
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Re: New Member with an issue

    Broken up it is SAP (Systems Applied Product) GUI(Graphic User Interface). The webpage also relies on SAP.

  6. #6
    Super Moderator Norm's Avatar
    Join Date
    May 2010
    Location
    Eastern Florida
    Posts
    22,205
    Thanks
    53
    Thanked 2,385 Times in 2,339 Posts

    Default Re: New Member with an issue

    Where does that fit in the problem?
    I have only worked with browsers loading html with the applet tag.

    Have you tried the AppletViewer? Here is a commandline that works for me with my applet:
    D:\Java\jdk-10\bin\appletviewer.exe http ://normsstuff.x10host.com/SmallBlob.html

    The space after http added to keep this site from parsing the URL
    If you don't understand my answer, don't ignore it, ask a question.

  7. #7
    Junior Member
    Join Date
    Jul 2019
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Re: New Member with an issue

    Quote Originally Posted by Norm View Post
    Where does that fit in the problem?
    Did you see the pic of the error I attached in an earlier thread, error1.jpg

  8. #8
    Super Moderator Norm's Avatar
    Join Date
    May 2010
    Location
    Eastern Florida
    Posts
    22,205
    Thanks
    53
    Thanked 2,385 Times in 2,339 Posts

    Default Re: New Member with an issue

    Did you see the pic of the error
    Yes. As I said, I know nothing about SAPGUI. Why is it giving that error message?
    How does SAPGUI relate to using a browser to view an html page with an Applet tag?
    I have had several applets and SAPGUI was never involved in any of them.
    If you don't understand my answer, don't ignore it, ask a question.

  9. #9
    Junior Member
    Join Date
    Jul 2019
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Re: New Member with an issue

    Why it gives me the error? That is what I'd like to know as well. The web page that I'm one has a field for file directory such as C:\Parts\PurchOrder\prt.txt. Right next to the field is a link to open a find file directory. You click the link it opens a popup screen of sorts, and you navigate to the file you need and then click open. The issue is when I click that link I get a spinning wheel and then error1 appears after 30 seconds of waiting or so. I don't know how the SAPGUI relates. I'm not a programmer and not the programmer for this web page.

  10. #10
    Super Moderator Norm's Avatar
    Join Date
    May 2010
    Location
    Eastern Florida
    Posts
    22,205
    Thanks
    53
    Thanked 2,385 Times in 2,339 Posts

    Default Re: New Member with an issue

    Why it gives me the error?
    What is the it that is giving the error? What program are you executing? What is the input to that program if any?

    Sorry, I can not help you with SAPGUI problems.

    Can you try the program with an older version of windows and an older version of java?


    some that can
    What is different about the PCs that work?
    If you don't understand my answer, don't ignore it, ask a question.

Similar Threads

  1. new member
    By tydoh in forum Member Introductions
    Replies: 2
    Last Post: August 29th, 2014, 09:36 AM
  2. New Member here
    By Shwe in forum Member Introductions
    Replies: 1
    Last Post: August 5th, 2013, 10:20 AM
  3. New Member
    By cyberakjain in forum Member Introductions
    Replies: 1
    Last Post: July 25th, 2013, 07:54 AM
  4. Java Issue / Cache issue
    By VisualPK in forum What's Wrong With My Code?
    Replies: 1
    Last Post: April 14th, 2012, 08:43 PM