Welcome to the Java Programming Forums


The professional, friendly Java community. 21,500 members and growing!


The Java Programming Forums are a community of Java programmers from all around the World. Our members have a wide range of skills and they all have one thing in common: A passion to learn and code Java. We invite beginner Java programmers right through to Java professionals to post here and share your knowledge. Become a part of the community, help others, expand your knowledge of Java and enjoy talking with like minded people. Registration is quick and best of all free. We look forward to meeting you.


>> REGISTER NOW TO START POSTING


Members have full access to the forums. Advertisements are removed for registered users.

Results 1 to 4 of 4

Thread: Problem regarding Android SDK and ADT update in Eclipse: Emulator response problem.

  1. #1
    Junior Member marksquall's Avatar
    Join Date
    Jan 2009
    Posts
    23
    My Mood
    Fine
    Thanks
    0
    Thanked 1 Time in 1 Post

    Unhappy Problem regarding Android SDK and ADT update in Eclipse: Emulator response problem.

    Dear javaprogrammingforums.com administrators and members,

    A greeting of peace.


    I am just starting to program in Android last week and so far I did not encountered any problems. But recently, I updated my Android SDK then my Eclipse complained that it needs now ADT version 14.xxx. So what I did is that I installed ADT version 14, but now the problem is that why the emulator took so so so long to load my very simple Hello World Android app? I left my emulator for almost an hour BUT the app (according to Eclipse Console Tab) says Installing HelloAndroid.apk...

    Before the updates, I recently used ADT 12 and uploaded only basic Android SDK tools (if I am not mistaken, I only downloaded SDK Platform Android 2.1, 2.2, 2.3.3), BUT the program work so smoothly...until now.

    I'm beginning to think that updating my SDK and ADT was such a bad idea, a big regret. Does anyone have an idea how to solve this thing?

    Thank you and more power.


    Warm regards,

    Mark Squall


  2. #2
    Junior Member
    Join Date
    Oct 2011
    Posts
    5
    My Mood
    Inspired
    Thanks
    2
    Thanked 1 Time in 1 Post

    Default Re: Problem regarding Android SDK and ADT update in Eclipse: Emulator response probl

    Hey man, I feel your pain... it did the same junk to me. I dont know any other way to do this, but you might have to just uninstall/reinstall, then pray that it works. anyhow, God bless, hope to help you in some form or fashion, or if not, maybe you can help me. But if you figure it out, please let me know. Thanks, Andrew Clark

  3. #3
    Junior Member marksquall's Avatar
    Join Date
    Jan 2009
    Posts
    23
    My Mood
    Fine
    Thanks
    0
    Thanked 1 Time in 1 Post

    Default Re: Problem regarding Android SDK and ADT update in Eclipse: Emulator problem

    Metalshadow24,

    Greeting of peace to you bro.

    Well, I have solved this problem. Well, you answered it correctly bro...I work back from scratch.

    I deleted my eclipse folder and extract a new one (in this case I am using Eclipse Indigo), reinstalled everything. Android SDK is already version 15 (as seen in Android SDK | Android Developers web site...hays how technology upgrades so so fast, but I cannot cope that fast sad to say. ). So I installed this new version, installed the Android Development Toolkit (ADT), which is also in version 15. Then like before, my simple hello world and input/output program works A-OK.

    Well, I guess if all else' fails, reinstalled again and again (using new updates if there's any).


    Thank you and Happy Halloween.



    Warm regards,

    Mark Squall

  4. #4
    Forum VIP
    Join Date
    Jun 2011
    Posts
    313
    My Mood
    Bored
    Thanks
    46
    Thanked 86 Times in 72 Posts
    Blog Entries
    4

    Default Re: Problem regarding Android SDK and ADT update in Eclipse: Emulator response probl

    You can improve the load time of the emulator with a few switches. Not sure how to do it from eclipse but from the command prompt use:

    $ emulator.exe -cpu-delay 0 -no-boot-anim -avd android22_hvga_480x800_32mb -scale 150dpi &

    Substituting your device name with android22_hvga_480x800_32mb

Similar Threads

  1. How to use Android in (Eclipse || NetBeans)
    By benglish in forum Android Development
    Replies: 2
    Last Post: October 21st, 2011, 06:28 AM
  2. how to add adt(android plugin) to eclipse from zip file ???
    By mahdi in forum Android Development
    Replies: 2
    Last Post: July 9th, 2011, 02:32 PM
  3. Eclipse Problem
    By The_Mexican in forum Java IDEs
    Replies: 2
    Last Post: December 8th, 2010, 08:02 PM
  4. video game problem - delay in response to arrow key presses
    By gib65 in forum What's Wrong With My Code?
    Replies: 6
    Last Post: October 17th, 2010, 07:39 PM
  5. [SOLVED] Java for loop problem and out put is not coming
    By thewonderdude in forum Loops & Control Statements
    Replies: 9
    Last Post: March 15th, 2009, 02:31 PM