Welcome to the Java Programming Forums

The professional, friendly Java community. 21,500 members and growing!

The Java Programming Forums are a community of Java programmers from all around the World. Our members have a wide range of skills and they all have one thing in common: A passion to learn and code Java. We invite beginner Java programmers right through to Java professionals to post here and share your knowledge. Become a part of the community, help others, expand your knowledge of Java and enjoy talking with like minded people. Registration is quick and best of all free. We look forward to meeting you.


Members have full access to the forums. Advertisements are removed for registered users.

Results 1 to 2 of 2

Thread: new jre6 conflicts with old jre (1.2.2)

  1. #1
    Junior Member
    Join Date
    Dec 2009
    Thanked 0 Times in 0 Posts

    Default new jre6 conflicts with old jre (1.2.2)

    hi All,

    i have a java program that uses Jre6 (for the Swing based GUI) but also jre1.2.2 (that Visibroker 45 needs to make CORBA API call). if i install jre 1.2.2 and then jdk6 (includs jre6) all is ok. but if after all is installed,
    i re-install jre 1.2.2 the GUI program will not start when i click on the jar file. i have a simple workaround to the problem (i just run: 'javaw -jar <jar file name>' and make sure in Path env variable the bin directory of jre6 is the first in the list or run:'<full path of javaw.exe in jre6 bin dir> -jar <jar file name>') and these options work great, but still it's very annoying i can't just click on jar file after i re-installed jre 1.2.2. it's more annoying since this program is used by a lot of people and it takes me long time to explain to them how to use the workaround/s in case of conflict (which there are sometimes). i've tried to change the default javaw.exe file/process that files of .jar extension are started with and nothing worked. it's got to be some jre conflict but i don't know what and how to fix it.


  2. #2
    Super Moderator Json's Avatar
    Join Date
    Jul 2009
    Warrington, United Kingdom
    My Mood
    Thanked 156 Times in 152 Posts

    Default Re: new jre6 conflicts with old jre (1.2.2)

    You should make sure you have the latest JDK (1.6) installed and when you compile your program and you need it to be compatible on a lower version you use the -source and -target directives.

    See javac - Java programming language compiler

    // Json

Similar Threads

  1. Swing incorrect behaviour from JRE5 to JRE6
    By singhkanhaiya in forum AWT / Java Swing
    Replies: 1
    Last Post: August 25th, 2009, 01:23 AM