for(int i = 0; i<allE().length; i++)
Employee  a = allE();
Normally you want to get the array of all employees outside the loop, then print out each employee information individually. Also, unless your toString() method is defined to print out the information with a newline at the end (it shouldn't), you should probably use the println() method.
I would also suggest picking better names for your methods and variables. Method names such as allE() make little sense to everyone else or what it does, and variable names such as a give no indication as to what it's holding.
Employee  employees = getEmployees(); // getEmployees is a rename of your method allE
for(int i = 0; i<a.length; i++)