Welcome to the Java Programming Forums


The professional, friendly Java community. 21,500 members and growing!


The Java Programming Forums are a community of Java programmers from all around the World. Our members have a wide range of skills and they all have one thing in common: A passion to learn and code Java. We invite beginner Java programmers right through to Java professionals to post here and share your knowledge. Become a part of the community, help others, expand your knowledge of Java and enjoy talking with like minded people. Registration is quick and best of all free. We look forward to meeting you.


>> REGISTER NOW TO START POSTING


Members have full access to the forums. Advertisements are removed for registered users.

Results 1 to 2 of 2

Thread: JRE 1.5 doc question

  1. #1
    Junior Member
    Join Date
    Jun 2010
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default JRE 1.5 doc question

    I have what is probably a really dumb question. I'm an intern filling in for our tech writer and my boss asked me to update the system requirements for our application. He said:

    "A Java error is seen in the (App name) Server app (JMX as well) when it is configured to use JRE 1.5. The JMX Server bath file was pointed at a 1.5 JRE. To work around the problem, I pointed JMX to a 1.6 version of the JRE. So... it looks like we need to update our system requirements in our Server docs."

    But when I look at our system requirements, they don't actually refer to a 1.5 JRE. They refer repeatedly to 1.4 and to Java 5.0. I read some stuff online that said Java 5.0 actually refers to 1.5+. So now I'm REALLY confused about what I actually need to edit.


    Supported platforms and minimum requirements for these configurations:

    *
    Windows
    o Microsoft Windows XP SP 3, Windows 2003 SP 1, or Windows 2008
    o 512 MB RAM
    o Intel Pentium 4 with 2.0 GHz or greater
    o 100 MB free hard disk space
    *

    Linux
    o Red Hat Enterprise Linux ES 5 (32-bit version)
    o 512 MB RAM
    o Intel Pentium 4 with 2.0 GHz or greater
    o 100 MB free hard disk space

    Additionally, Java Runtime Environment (JRE) or Java Development Kit (JDK) version 5.0 is required for all configurations.

    JMX Client

    When using a Java 5.0-based application acting as the client to a remotely running (App name) Server JMX server, you will need the following:

    * Any platform that supports Java 5.0
    * Java Runtime Environment (JRE) or Java Development Kit (JDK) version 5.0

    Java 1.4 client

    When using a Java 1.5-based application using the foundatino-java14client.jar extraction toolkit library to connect to a remotely-running (App name) Server JMX Server, you will need the following:

    * Any platform that supports Java 1.4 or later
    * Java Runtime Environment (JRE) or Java Development Kit (JDK) version 1.4 or later.

    I'm totally confused. Any idea what I am actually supposed to edit? Thanks for any tips you can give me...


  2. #2
    Super Moderator Json's Avatar
    Join Date
    Jul 2009
    Location
    Warrington, United Kingdom
    Posts
    1,282
    My Mood
    Happy
    Thanks
    70
    Thanked 158 Times in 154 Posts

    Default Re: JRE 1.5 doc question

    Yeah as of 1.2 Java is also known as Java 2 just like 1.5 is known as Java 5.0 and 1.7 will most likely be Java 7.0.

    See Java versioning and terminology, 1.6 vs 6.0 openjdk vs sun - Stack Overflow

    // Json